ReportToPDF Module Not Found Error

Download and share automation modules and examples.
QATest879
Posts: 22
Joined: Fri Jul 02, 2021 2:35 pm

ReportToPDF Module Not Found Error

Post by QATest879 » Tue Aug 03, 2021 7:51 pm

Good afternoon.

I have been using ReportToPDF for a while and it's been working good until just recently. I'm not sure what caused it to stop working but here are my steps.

I put some files in the bin/debug folder that is part of the project folder. I don't think that's what caused the issue but it happened around this time. I didn't delete any of the files in the debug folder as far as I know, though, I just added some new ones, so I don't think that could have caused this issue... I'm not sure what else that I did could have caused the problem though...

After the problem started, I was getting 23 warnings every time I ran my test telling me that there were issues with the module. It said "ReporttoPDFModule could not be found. Could not load file or assembly "Ranorex.Core, Version=9.3.20."

After that I decided to update my Ranorex to version 10 but now I am getting this error instead: "Rethrow Exception within PDF Module (Necessary for correct error value)."

The module is there on the testsuite and I have the automation helpers loaded on the left panel, so I'm not sure what it's unable to find now. I don't think I deleted anything.

Any help would be appreciated, thank you.

User avatar
tmcdoniel
Certified Professional
Certified Professional
Posts: 78
Joined: Mon Dec 07, 2020 6:30 pm

Re: ReportToPDF Module Not Found Error

Post by tmcdoniel » Wed Aug 04, 2021 4:37 pm

I suggest creating a new solution and adding the ReportToPDF functionality in order to determine whether it is unique to the solution that is having problems or whether there is something else going on. In other words, does the new solution also exhibit the same problem?

In addition, if you have source control, perhaps you could revert to the time before the problem existed.
Sales Engineer @ Ranorex

Fergal
Certified Professional
Certified Professional
Posts: 401
Joined: Tue Feb 18, 2014 2:14 pm
Location: Co Louth, Ireland
Contact:

Re: ReportToPDF Module Not Found Error

Post by Fergal » Fri Aug 06, 2021 2:31 pm

QATest879 you could try going to Ranorex Automation Helpers context menu > Manage Packages > Installed tab to confirm that Ranorex ReportToPDF is installed. If it is, check to Updates tab to see if it needs updating.